
Microsoft Excel 2003: Part III 
Creating Formulas 

Windows XP 
 
 
 

 
 
 
Microsoft Excel 2003  

 
Microsoft Excel is an electronic spreadsheet program.  Electronic spreadsheet 

applications allow you to type, edit, and print spreadsheets.  Excel can be used for 

financial, statistical, or list information.   

 

Formulas 
Learn how to use Excel to do the math for you by typing formulas into cells.  

 
Mathematical Operators 
Excel uses familiar signs to build formulas. Note: All formulas start with the ‘=’ sign.  

 

Add (+) =10+5 

Subtract (-) =10-5 

Multiply (*) =10*5 

Divide (/) =10/5 
 
Cell References 
Cell references identify individual cells, rows, and/or columns in a worksheet. They 

tell Excel where to look for values to use in a formula. 

Cell 
references 

Refer to values in 

A10 the cell in column A and row 10 
A10,A20 cell A10 and cell A20 
A10:A20 the range of cells in column A and rows 10 through 20 
B15:E15 the range of cells in row 15 and columns B through E 
A10:E20 the range of cells in columns A through E and rows 10 through 

20 
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Entering a Formula 

 

• Click in the cell where you want to enter a formula and manually enter your 

formula in that cell, i.e. =A2*B3, =SUM(G2:G27), =(S28-T28)/T29. 

 

OR 

 

• You can select individual cells that you want to include in your formula by 

clicking with your mouse in each cell.  Then put formula signs on your 

keyboard.  For example, to have formula =A2*B3, you would follow these 

steps below: 

• Enter ‘=’ from your keyboard in the cell you want to enter formula 

• Click on cell A2 with your mouse  

• Enter ‘*’ from your keyboard to have multiplication  

• Click on cell B3 with your mouse 

• When you are done entering your formula hit the Enter key to finish it. 
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Note: For complex formulas, all operations within the parenthesis are calculated first!

 

OR 
Do one of the following: 

 

1. Open the Insert menu and select Function… 

 

2. Click the AutoSum button on the Standard toolbar. 

 

3. Click the Insert Function button next to the Formula Bar. 

 

 



 
Insert Function 
You may need to click the down arrow and select from a drop-down list. 
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The function will be explained at the bottom of the dialog box.  It describes what is 

needed in your formula. 

• Select your function and press OK.  The Functions Arguments dialog box 

appears. 

• Verify the values listed in the Number 1 box and press OK.  If the values are 

incorrect you can retype your values in this box. 

 

 

 

 

 

 

 

 

 

Click 
down 
arrow to 
get more 
functions. 

 

• Your results will appear on the worksheet in the active cell. 

 

 

•  

 



 

AutoSum 
 

The AutoSum   button on the Standard toolbar will quickly 

create a formula with the Sum function.  

• Place the cursor in an active cell directly below a column 

of numbers or at the end of a row of numbers that you 

wish to add up. 

• Click on the AutoSum button. 

• The formula will automatically appear in the active cell. Press Enter. 
 

 

You can click the down arrow next to the button and select other functions, such as 

Average, Count, and Maximum.  Selecting More Functions… will cause the Insert 
Function dialog box to appear. 

 

Formula Bar 
 

The formula bar contains an Insert Function button that when clicked will cause the 

Insert Function dialog box to appear. In addition a green checkmark and a red ‘X’ will 

appear for accepting or canceling your formula respectively. 

 

 
 

• Select the active cell where you would like formula results to appear. 

• Select the Insert Function button where you will work with the Insert Function 

dialog box as previously explained. 

• Press OK and your results will appear in the formula bar. 

• Click the green checkmark to accept or the red ‘X’ to cancel your formula OR you 

can click OK to accept in dialog box or Cancel to cancel your formula. 
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Copying Formulas 

Formulas can be copied to adjacent cells by dragging the fill handle down to 

those cells.  Prior to copying formulas it is important that you understand what 

will occur to the formula as it is copied. 

Relative and Absolute Cell References 

Relative (1) Every relative cell reference in a 

formula automatically changes when the formula is 

copied down a column or across a row. As the 

example illustrated here shows, when the formula 

=C4*$D$9 is copied from row to row, the relative 

cell references change from C4 to C5 to C6.  

Absolute (2) An absolute cell reference is fixed. 

Absolute references don't change if you copy a 

formula from one cell to another. Absolute references have dollar signs ($) like 

this: $D$9. As the art shows, when the formula =C4*$D$9 is copied from row to 

row, the absolute cell reference remains as $D$9.  

Example 
 
Use absolute references to refer to cells that you don't want to change as the 

formula is copied. References are 

relative by default, so you would 

have to type dollar signs, as shown 

at number 2 in the example, to 

change the reference type to 

absolute.  

Imagine that you receive a package 

of discount entertainment coupons 

offering a 7 percent discount for 
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video rentals, movies, and CDs. You wonder how much you could save in a 

month by using the discounts. You could use a formula to multiply those 

February expenses by 7 percent.  

• Type the discount rate 0.07 in the empty cell D9 and then type a formula 

in cell D4, starting with =C4*.  

• Enter cell address D9 and press the F4 function key to make an absolute 

reference to the cell (will add dollar signs). Your formula would multiply the 

value in cell C4 by the value in cell D9.  

• Next, copy the formula from cell D4 to D5 by using the fill handle . As 

the formula is copied, the relative cell reference changes from C4 to C5, 

while the absolute reference to the discount in D9 does not change; it 

remains as $D$9 in each row it is copied to.  

 
Note:  Formulas can also be copied to non-adjacent cells: 

• Select cell with formula  

• Right-click on cell and select Copy 

• Right-click on cell you would like to paste formula into and select Paste.  

The formula will change to accommodate the numbers in the cells closest 

to the formula. 

 

EXAMPLE: 
When copying the formula from column A to column C, the relative values will 

change to accommodate the new values in column C. 
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Editing a Formula 
 

• Go to the cell that has the formula that you would like to edit by: 

 

1.  Double-clicking in the cell containing the formula 

2.  Single-click on cell with formula and press F2 key 

  

• Use the arrow keys to move the cursor and type the changes that you 

want to the formula.  Remember you can use the Delete or Backspace 

keys to erase one character at a time. 

• Be sure to hit the Enter key to complete your changes and to display your 

results. 

 

3. Single-click on cell with formula to select the cell and click in 

the formula bar next to fx key and make changes.   

 

• The formula bar will feature a green checkmark to accept changes and a 

red “x” to cancel changes you make to a formula. 

 
 
 

Note: To erase the formula completely, simply click on the cell and press the 

Delete key on the keyboard. 
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Display formulas on your worksheet 

• On the Tools menu, point to Formula Auditing, and then click Formula 

Auditing Mode .  

• On the File menu, click Print.  

• Under Print what, select an option to print the selection, the active 

sheet(s), or the entire workbook.  

Note: If you want to show which formula belongs to which row and column 

headings, go to File>Page Set up>Click on Sheet tab>Check on Row and 
Column headings box.  By doing so, you will be able to see row numbers 

and column names on your printout. It’s not also a bad idea to check on 

Gridlines box on the same Sheet tab to clearly see each cell with distinctive 

formulas.  See below in an example. 

 

If you want to print more than one worksheet at the same time, select the 

worksheets before you print by holding down the Shift button on your 

keyboard to select all adjacent sheets.  For non-adjacent sheets, use Control 
button on your keyboard and click on individual sheets. 
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Linking Data 

You can link data between cells, worksheets, and workbooks.  This might be 

useful if you have data in one workbook that you would like to view in other 

areas.  If you link the data, then changes you make to that data in the original 

workbook will be reflected in all of the workbooks or worksheets linked to it. 

 
To link cells, worksheets, workbooks: 

• Click within the cell that you want the link to appear (Destination cell) 

and type the equal sign. 

• Then go to the cell, worksheet, or workbook that has the data (Source 

cell) that you want to link to.  Click within the cell or type the cell 

address (Note:  For a linked worksheet or workbook you need to type 

the entire path, so it is easier to just click within the cell).  You will 

notice that Excel will highlight your Source cell at this time. 

• Press Enter while your Source cell is still highlighted with marching 

ants around (DO NOT CLICK ANYTHING ELSE).  You will 

immediately be back to the workbook or worksheet with destination cell 

and see your result instantly. 
Destination Cell     Source Cell 

 

 

 

 

If you make changes in your Source cell, 

changes will apply to Destination cell 

instantly. 
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Seeing your Changes Side by Side in Two Windows 

If you like to see your changes in two worksheets or two workbooks after 

linking data, follow the steps below. 

1. Click on Window on menu bar and select New Window.  You will 

notice on your taskbar at the bottom of your screen that Excel opens a 

duplicate workbook by adding ‘2’ at the end of the file name.  See 

example below. 

 

2. Next, click on Window on menu bar again and click on “Compare side 
by side with filename.xls:2” as shown below. 

 

3. You will see two windows opened side by side vertically on your 

screen.  If two windows opened horizontally, click on Arrange on your 

Window on menu bar and select Vertical from Arrange Window dialog 

box. 

 

Note:  Make sure one of your windows select the sheet with Source cell 

and the other, Destination cell for you to be able to see applied changes 

instantly. 
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Formula Exercises 

 
 
Exercise 1: Using Formulas – Click here for Using Formulas Worksheet  
 

Create a formula to add  

 

Before you work with the data that's on the worksheet, create a formula in an 

empty cell in column A. Select cell A2, add 183 to 39, and press ENTER to 

display the result. Next, click cell A2 to see the formula in the formula bar 
.  

Here's how    Enter an equal sign (=), type 183 and the plus sign operator (+), 

type 39, and then press ENTER. The answer is 222.  

Note:  If the formula bar is not at the top of the worksheet, on the Tools menu, 

click Options. Click the View tab, and select the Formula bar check box.  

 

Create formulas for other arithmetic  

 

In column A, enter three separate formulas in three separate cells. Enter a 

formula to subtract 39 from 183. Enter another formula to multiply 183 by 39. 

Finally, enter a formula to divide 183 by 39.  

Here's how    To subtract, =183-39 (answer, 144); to multiply, =183*39 (answer, 

7137); to divide, =183/39 (answer, 4.692307692).  

Add up a column of numbers  

 

Now you'll work with values that already exist in the worksheet. Use AutoSum to 

total the January values in column D.  

Here's how    Click in cell D8, click AutoSum on the Standard toolbar, and 
then press ENTER. The total is 95.94.  
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Note:  If the AutoSum button is not available, click the Toolbar Options arrow 
at the end of the Standard toolbar, then click Show Buttons on Two Rows. 

 

Copy a formula  

 

Copy the formula from cell D8 to cell E8.  

Here's how    Use the fill handle to copy the formula in cell D8 to cell E8. 

The February total is 126.93. 

1. Select cell D8, and then position the mouse pointer over the lower-right 

corner of cell D8 until the black cross (+) appears.  

2. Then drag the fill handle over cell E8. When you release the fill handle, 

you should see the February total 126.93 in cell E8.  

 

Add up a row of numbers  

 

Now you'll try something new by totaling the numbers in a row rather than in a 

column. The procedure is the same. You just click in a different place. Use 

AutoSum to total the figures in row 6. Here's how Click in cell F6, click 

AutoSum on the Standard toolbar, and then press ENTER. The answer is 

48.00.  

Exercise 2: Cell References - Click here for Cell References Worksheet

 
Type cell references in a formula  

 

In cell E9, type a formula using cell references to total January video rentals and 

February CD expenses.  

Here's how    In cell E9, type =SUM(B5,C7). Notice that when you type B5, 

Excel highlights cell B5, and when you type C7, Excel highlights cell C7. Enter 
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the formula exactly as shown, and then press ENTER to display the formula 

result, which is 37.96.  

Notes: You can get the same result by typing =B5+C7. The SUM function is 

most useful when you have more than a few values to add.  

Select cell references for a formula  

 

In cell E10, try entering the same formula by clicking cell references instead of 

typing them. Here's the formula: =SUM(B5,C7) 

1. Type an equal sign in cell E10.  

2. Then type SUM followed by an opening parenthesis.  

3. Click cell B5, and then type a comma.  

4. Click cell C7, type a closing parenthesis, and then press ENTER to get the 

result 37.96.  

 

Use an absolute reference in a formula  

 

In cell D11, recreate the example from the lesson by figuring out how much you'd 

save with a 7 percent discount on February's video rentals, movies, and CDs.  

1. In cell D11 type the discount rate, 0.07.  

2. In cell D5 type =C5*$D$11 (you can hit F4 function key after typing D11 

to turn that cell into absolute cell address $D$11) and then press ENTER. 

The result is 1.12.  

3. Next copy the formula down through row 7 by selecting cell D5 and 

positioning the mouse pointer over the lower-right corner of that cell until 

the black cross (+) appears. Then drag the fill handle down the rows, 

releasing it in cell D7. The results are 2.24 in cell D6 and 2.10 in cell D7.  

As the formula is copied, the relative cell references change from C5 to C6 to C7, 

while the absolute reference to cell D11 does not change. It remains as $D$11 in 



each row it is copied to, as you will see if you click cells D6 and D7 and look at 

the result in the formula bar near the top of the worksheet.  

 

Add up several results  

 

Total the savings from the previous exercise by entering a formula into cell D8.  

Here's how    Select cell D8 by clicking it, click AutoSum on the Standard 

toolbar, and then press ENTER. The result is 5.46. You could also type 

=SUM(D5:D7).  

 

Change values and totals  

 

See formula results automatically updated when you make a revision. In cell B6 

change "16.00" to "28.00." The total in B8 will be updated, in this case to 107.94. 

If you want, change any other values to see the total updated again. Note    If 

results are not updated, on the Tools menu, click Options. Click the Calculation 

tab, and select the Automatic check box.  

Exercise 3: Functions and error values - Click here for Functions Worksheet

 

Excel needs very precise instructions. This means that formulas must be typed 

exactly as shown. Missing a comma or parenthesis, or misspelling a function 

name, will produce errors.  

Find an average  

 

In cell D8, find an average of the totals in column B and column C.  

Here's how    Select cell D8, click the arrow on the AutoSum button , and 

click Average in the list. Then press ENTER. The answer is 113.43.  
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Find the largest number  

 

You don't need a formula to determine that 95.94 is the largest number in column 

B. But imagine that the list is long, in which case a formula would be useful. In 

cell B9, use a formula to find the largest number.  

Here's how    Select cell B9, click the arrow on the AutoSum button, and click 

Max in the list. Then press ENTER.  

Before you go on to the next exercise, delete the result in cell B9. 

Find the smallest number  

 

Again, it's obvious that 15.96 is the smallest number in column C, but try using a 

formula anyway in cell C9 to find the smallest number in column C.  

Here's how    Select cell C9, click the arrow on the AutoSum button, and click 

Min in the list. Then press ENTER.  

Before you go on to the next exercise, delete the result in cell C9. 

Display and hide formulas 

 

Display all the formulas in the worksheet, and then hide all the formulas.  

Here's how    On the Tools menu, point to Formula Auditing, and then click 

Formula Auditing Mode. To hide the formulas, click Formula Auditing Mode 

again. You can also press CTRL+` (next to the 1 key) to display and hide 

formulas.  



Error values  

To create an ##### error so that you can fix it, make column B narrower by 

dragging the column boundary until the ##### error appears. To do this, move 

the pointer over the column heading until the pointer changes to a dark cross 

with two arrow points.  Double click on the arrow and Excel will adjust the column 

width just right.  OR you can manually adjust the column width by dragging the 

column. You may have to drag the column boundary several times to make the 

column narrow enough to create the ##### error. 

 

Then resize the column again to make the formula result appear. The display is 

updated whenever you drop the column boundary in a new position, so it can 

take more than one try to make the column wide enough to display the formula 

result.  

 

Error value #Name?  

 

Here's another error you can create and fix. Use the SUM function, but misspell 

it.  

In cell B8, delete the total 95.94 and then type =SUME(B4:B7) (notice the extra 

"E" typed in the function name). After you press ENTER you'll see #NAME? due 

to the spelling error.  

To fix the error, select cell B8 and then place the pointer in the formula bar. Or 

double-click in the cell to display the formula and then edit it. Delete the "E" from 

"SUME" and press ENTER. The formula result will appear correctly. 
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